In case you receive the mentioned error while trying to install rmagick then simply issue the following:

# yum install ImageMagick-devel

Once ImageMagick-devel is installed then you can retry installing rmagick using:

# gem install rmagick

Miroslav Mirkov

Just some random thoughts